Skip to main content

VSP API ignoring resolution= value?

The membership database is currently undergoing upgrading/testing. Web functions that involve an interface with the member database (webobs, etc.) may experience intermittent problems. We hope to have this issue resolved within 24 hours (by 5pm Eastern Time on October 1st or 12:00 UT). Thank you for your patience.
dks's picture
dks
Offline
Joined: 2010-07-26

It appears that no matter what value I give with the "resolution" parameter I get a rather small 72 dpi image. An example URL is http://www.aavso.org/vsp/chart?name=v452+cas&charttitle=v452+cas&fov=24&resolution=120&maglimit=18&north=up&east=left&forcelines=on&othervars=all.  When I click on the resulting chart I get 600x750 chart.  I get the same resolution chart when I substitute 150 or 75, or seemingly any other value for resolution.

Thanks,

Shawn (DKS)

I don't think that the intent
Herr_Alien's picture
Herr_Alien
Offline
Joined: 2012-04-24

I don't think that the intent behind the www.aavso.org/vsp/chart URL is to produce high resolution charts to begin with, especially since the output is an HTML page rather than just a .PNG image.

I would use http://www.aavso.org/cgi-bin/vsp.pl to generate charts of various resolutions. I think it is also the only URL that the VSP API documentation mentions (could be wrong though).

--- edited ---

... and I was wrong :). The "www.aavso.org/vsp/chart" URL is indeed mentioned in the API. Until its functionality is fixed, my suggestion is to stick to "http://www.aavso.org/cgi-bin/vsp.pl".

Works but not as handy
dks's picture
dks
Offline
Joined: 2010-07-26

Thanks for the suggestion - I tried it out and using the "cgi-bin" path does give a chart of the requested size. However, I generally need both the chart (for matching stars to my images) and the CCD photometry table to reduce the images.  I'll send a note directly to the AAVSO maillist since they may not be aware of the bug.  In the meantime I can make two web requests using the "cgi-bin" path: one to get just the chart and one with "ccdtable=on" to get just the photometry data.

Shawn

Could indeed be a bug.
Herr_Alien's picture
Herr_Alien
Offline
Joined: 2012-04-24

Yeah, I guess. I didn't try to get the CCD table, so I'm not sure if they re-send the map. If they do, then the two calls will end up transfering more data than actually needed. In that case, then yes, I would think of it as a bug.

AAVSO 49 Bay State Rd. Cambridge, MA 02138 aavso@aavso.org 617-354-0484