VStar
version 2.21.3

User Manual

David Benn
Lead Developer
dbenn@computer.org
# Table of Contents

Introduction......................................................................................................................................3
Observation Sources..........................................................................................................................6
  Load from AID.................................................................................................................................6
  Load from File................................................................................................................................9
  Additive Loads...............................................................................................................................13
The Plot Pane....................................................................................................................................14
Observation List................................................................................................................................23
Observation Details Dialog.............................................................................................................30
Plot Control Dialog..........................................................................................................................34
Information Dialog.........................................................................................................................39
Filtering Observations.....................................................................................................................41
Phase Plots........................................................................................................................................50
Period Analysis................................................................................................................................57
  Introduction.......................................................................................................................................57
  DCDFT in Detail.................................................................................................................................59
  Harmonics.......................................................................................................................................62
  Creating Fourier Series Models.........................................................................................................63
  Other DCDFT options: Period and Frequency Range.......................................................................67
  CLEANest........................................................................................................................................69
Polynomial Fit....................................................................................................................................80
Time-Frequency Analysis...............................................................................................................90
Plug-ins...........................................................................................................................................99
Preferences.......................................................................................................................................101
Log....................................................................................................................................................111
Scripting VStar...............................................................................................................................113
Glossary............................................................................................................................................117
References and Useful Links............................................................................................................122
  General Information on VStar and Variable Star Observing.........................................................122
  Useful Links for Period and Time Series Analysis (TS and WWZ)..................................................123
  Useful Links for Polynomial Fit........................................................................................................123
  Useful Links for Regular Expressions (for Observation List Pattern Search)...............................123
Further Reading..............................................................................................................................125
License Information.........................................................................................................................127
Revision History..............................................................................................................................128
Introduction

VStar is a free, open source, multi-platform application for visualizing and analyzing time-series data. It is primarily intended for use with variable star data, but any data that can be represented in terms of a Julian Date and magnitude (or other numerical values) is suitable.

The following figure shows that VStar is able to load observations from a variety of sources, including the AAVSO International Database (AID), files, and other sources (such as http streams). The *Observation Sources* section describes what kinds of data can be loaded into VStar and from what sources.
When in “online mode” (loading from AID), VStar also requests information from the Variable Star Index (VSX) about the requested object, such as period, variable type, spectral type and discoverer.

VStar allows data to be viewed and filtered via plots or tables. The details of each observation can be viewed individually or in tabular form. Data and plots can be saved or printed. A mean plot can counteract the effect of noise in data and provide an indication of the extent of signal present.

Phase plots can be created, assuming a certain period, revealing the shape of a star’s light curve in a way that a raw data plot may not.

Period analysis can be applied to reveal one or more periods in the data. Models can be created to represent the essence of a light curve and to subtract one or more periods from the data, the “residual data” being amenable to further analysis. Time-frequency analysis permits changes in period over time to be discovered.

VStar is written in the Java programming language, requiring at least version 1.6 to run on Windows, Mac OS X, Linux, and OpenSolaris. New functionality can be added via plug-ins (from a plug-in library) or can be written by anyone with knowledge of Java or other languages that target the Java Virtual Machine.

The following figure shows the main window’s toolbar and tabs.
The two toolbar buttons below switch between “raw data mode” (or “raw mode” or “light curve mode”) and “phase plot mode” (or “phase mode”).

The tabs labeled Plot, Observations, Means, Model, and Residuals show the same data in different forms or reveal different facets of the underlying data.

In both raw and phase mode the Plot pane contains a multi-series plot of the loaded dataset along with any “synthetic” series, such as means, model, residuals, or filtered observations. Various attributes of the plot can be customized. See the Plot Pane section for more detail.

The Observations pane reflects the Plot pane in tabular form. It also provides the ability to search the data and create filtered subsets from search results or a manual selection of observations. See the Observation List section for more detail.

The remaining 3 panes – Means, Model, and Residuals – show “synthetic” data in simple tabular form.

The remainder of this document describes different aspects of VStar’s functionality. To learn more about the context in which VStar was developed, see Benn (2012).

Note that user interface screenshots of components such as file choosers, dialogs and windows were taken from VStar running on Mac OS X and will differ from other operating systems such as Windows and Linux.
Observation Sources

Observations can be loaded into VStar from a variety of sources. Out of the box, observations can be loaded from the AAVSO International Database (AID) or files conforming to one of two formats (described in the Load from File section).

Observations from other sources (e.g. other AAVSO sources, Kepler, SuperWASP, ASAS) can be loaded via plug-ins found in the AAVSO Plug-in Library (http://www.aavso.org/vstar-plugin-library).

Load from AID

To load a set of observations from the AID, ensure you are connected to the Internet, then select New Star from AAVSO Database... from the File menu or click the button at the left of the toolbar.

The following dialog will appear:
If the name or AAVSO Unique ID (AUID) of a variable star is entered into the Star text box, this will be used instead of the currently selected object in the Group section's Star dropdown.

Names must be written as found in VSX (the primary name or one of its aliases). See https://www.aavso.org/vsx/index.php?view=search.top

The “10-Star Tutorial list (North)” contains all stars from the “10 star” tutorial document. The “11-Star Tutorial list (South)” contains all stars from the “Southern Gems” tutorial document. Other groups can be created via the Preferences dialog.

If the Add to current? checkbox is selected, observations loaded from AID will be added to those already loaded into VStar. See the Additive Loads section below for further details.

Either a Julian Date range must be specified or All Times? selected. This determines the time range over which data should be loaded.
If the Minimal Fields? checkbox is selected, a minimal set of fields for each observation is loaded to reduce load time.

By default, Visual and Johnson V bands are selected for download, but more can be specified.

Space-delimited observer codes can optionally be specified to further reduce the number of observations loaded.

In addition, a VeLa expression can be entered to examine each observation and determine whether it should be loaded. See also the Glossary, Observation List and Filtering Observations sections.

If the requested object does not exist or there is no data for the object in AID or for the specified date range, a message box will appear to that effect, otherwise the available data will be loaded, the light curve plot, observation list, and mean series created. If visual or V band data exists, corresponding observations will be initially visible; this can subsequently be changed via the Plot Control Dialog (see View menu). Otherwise, the band with the most observations will be displayed initially.
Load from File

To load observations from an AAVSO download format file or “simple” file, select the New Star from File... menu item from the File menu or click the second-to-left-most button in the toolbar.

The file chooser that opens defaults to the observation source “Download or Simple”. Such files must conform to one of two formats:

- AAVSO download format

- Simple format, consisting of lines of the form:

  Julian Date,Magnitude,[Uncertainty],[Observer Code],[Validation Flag]
  or simply:
  Julian Date,Magnitude

In both cases (AAVSO download and simple formats), lines can either be comma or tab separated. For the simple format, a space may instead be used as a delimiter. Notice that delimiters must be retained for optional values, e.g. in the following simple file example, uncertainty and validation flag are omitted:

2456423.123,4.2,,BDJB,

Comments may be used in simple format and AAVSO files by starting a line with a “#” character. Everything else on that line will be ignored.

Magnitude values may be prefixed by negative signs, e.g. -4.2.

Lines starting with “#” are considered to be comments, except for a line of the form:

#NAME=SomeObject
If present, this directive will lead to “SomeObject” being displayed in the plot title. Whereas the AAVSO download and some other formats contain object name information, the simple format does not. This directive overcomes that shortcoming and can also be used with AAVSO download format files.

As mentioned already, selecting the New Star from File... menu item invokes the following file chooser:

Choosing a conformant file and clicking the Open button will load the observations, leading to the same result as a Load from AID operation. If the file is not of a suitable format, an error dialog will be displayed.

Note that in earlier versions of VStar, instead of observation sources being selectable in the file chooser as shown above, they appeared as File menu items. It is still possible to have observation source plug-ins appear in the File menu instead of the file chooser's Source selector by selecting the Show all observation sources in File menu? checkbox in plug-in preferences. See the Preferences section.

A VeLa expression can be entered to examine each observation and determine whether it should
be loaded. See also the Glossary, *Observation List* and *Filtering Observations* sections.

Observations of other kinds can be loaded via particular observation source plug-ins. See the AAVSO plug-in library for more. Any observation source plug-in capable of reading from a file or web source via the corresponding URL (Uniform Resource Locator) will appear in the *Source* selector in the file chooser. Other observation source plug-ins will appear as *File* menu items.

For those observation source plug-ins permitting a URL (Uniform Resource Locator or web page address) as an alternative to a file to read observations from, the dialog will have a *Request URL* button as shown above and in the following example:
Selecting the button will yield this dialog:

![Enter URL dialog](image)

Some observation source plug-ins may only accept a URL as input in which case the following form of the Enter URL dialog will be presented to the user.
For example, the URL for an AAVSO download format file can be obtained by copying the first link (e.g. right mouse button click on Windows or control-click on Mac) on the “Your Data Request Has Been Filled” page that results from completing the download form, e.g.

![Your Data Request Has Been Filled](image)

For AAVSO download format requests, it may be simpler to download the file to your computer and open it normally via the file chooser. For some other observation source plug-ins, such as the one for ASAS observations, use of a URL may seem more natural. See also the Plug-ins section.

The second file dialog above also shows that observation source plug-ins may handle additional file extensions (e.g. “.fits”), aiding in file list filtering in the file chooser.

**Additive Loads**

If the Add to current? checkbox is selected in any observation source dialog, the loaded observations will be added to any already loaded, irrespective the object. In this way, observations from different sources can be combined in a single VStar session.
The Plot Pane

The Plot Pane provides a view of the currently loaded dataset as a scatterplot of observations, graphing brightness vs time (or phase). This is referred to as a “light curve”. Here is a light curve for LX Cyg:

![Light Curve for LX CYG](image)

The same dataset in phase plot mode, folded on a period of ~582.188 days, is shown below:
Other than the fact that this shows a phase plot, the other differences from the light curve view are that:

- A mean series has been added. See Plot Control Dialog section.
- Period and epoch are shown as a sub-title.
- The X axis is labelled “Phase” instead of “Time”.

Selecting a data point with the mouse sets the cross-hairs, e.g.

Consider the following W UMa light curve:
Once selected, a number of operations can be carried out:

- the observation can be excluded via Edit → Exclude Selection;
- the details of the observation can be viewed via the Observation Details Dialog or Observation List (see the corresponding sections for more detail);
- attributes of the selected observation can be made available for observation filtering (see the Filtering Observations section);
- the Plot Pane can be zoomed or panned; these operations are covered next.

On the W UMa plot above, it would be useful to be able to see more detail on a smaller time scale. This is possible in a number of ways:

- Drawing a bounding box with the mouse (click and drag) around an area of the plot. To zoom out again, a click-drag-left mouse gesture is used.

- Selecting a point on the plot then using the zoom buttons in the toolbar or the View menu’s Zoom In and Zoom Out items:
• Use the zoom items of the context menu\(^1\) (e.g. by right-clicking on Windows, ctrl-click on Mac OS X):

Using the first method above, drawing a bounding box around the section near the cross-hairs to the lower left (JD range: 2454881 to 2454949, magnitude range: 7.5 to 8.75), gives a view like this:

\(^1\) Note that this context menu allows other aspects of the plot to be modified, such as the range and domain axis titles via Properties...
Even at this “magnification” level, one can begin to glimpse that something other than vertical lines exists in this plot. Zooming in further, this time from around JD 2454904 to 2454905 (magnitude 7.7 to 8.4), the following is revealed:
When looking at a magnified view, the pan left, right, up, down View menu items or toolbar buttons can be used to move to regions of the plot not visible.

For example, the following is the result of panning the above plot left and down several times:
The following shows a phase plot of this dataset at a period (from VSX) of 0.33363749 days:
The contents of the Plot Pane can be saved to a file as a PNG image or printed via the File menu’s Save... and Print... items or the corresponding toolbar buttons.

An example of the Save Dialog is shown below. All plot image files are saved in PNG format. If the filename entered does not have a “.png” or “.PNG” suffix, VStar will add this. In the example below, when the Save button is clicked, the current plot will be saved to a file called “omiCetLC.png”.

The Print Dialog looks like this on a Mac OS X machine:
**Observation List**

VStar’s observation list is selected via the Observations tab in the main window and consists of a tabular view of the loaded observations and a Search Creation pane.

The following shows the observations list with eta Aql observations loaded from AID.

![Observation List](image)

The most obvious feature is the tabular list of observations consisting of columns relating to each observation, e.g. **Magnitude, Band, Comp Star 1**. The figure shows a row having been selected by the user. Switching to the **Plot** tab would reveal that the cross-hair was pointing to the same observation in the light curve or phase plot.

Columns can be rearranged by dragging the column headers, and observations can be sorted by column by single-clicking on the column header. In any mode (raw or phase plot), the default is for observations to be sorted by Julian Date.

The set of columns that appear in the observation list varies with the observation source (e.g. AID, files of particular type).
Something not obvious at first glance is that the observation list mirrors the plot. In other words, if a particular band/series is visible on the plot, it will also be visible in the observation list. It is possible to override this by selecting the **Show all data?** checkbox. Note this will not affect the plot. The same is true for the **Search** feature. Selecting the **Regular Expression** radio button (selected by default) and typing a *regular expression* into the text box to the left of the **Apply** button, followed by clicking that button will:

- Look for a match across values in all columns.
- Filter the list based upon the match.

If no match is found, no observations will be displayed. Clicking the **Reset** button will restore the normal observation list. Note that when **Show all data?** is selected, the Search pane is disabled.

The following shows a pattern search for the word “moon”, resulting in a listing that consists only of observations in which the word “moon” appears somewhere, specifically: in the Comments column. In this example, the comments column needs to be expanded to see some occurrences of the pattern, e.g. those near the middle beginning with “Clear. Wa...” when expanded, show “Clear. Waxing moon.”

<table>
<thead>
<tr>
<th>Time</th>
<th>Calendar D.</th>
<th>Magnitude</th>
<th>Uncertainty</th>
<th>Band</th>
<th>Observer</th>
<th>Validation</th>
<th>Comp Star 1</th>
<th>Comp Star 2</th>
<th>Charts</th>
<th>Comment</th>
<th>Comments</th>
<th>Comments</th>
<th>Transform</th>
<th>Airmass</th>
</tr>
</thead>
<tbody>
<tr>
<td>2455757.69722</td>
<td>2011 JUL 2 4.1</td>
<td>0</td>
<td>Visual</td>
<td>MDP</td>
<td>Good</td>
<td>3.7</td>
<td>4.4</td>
<td>10star</td>
<td>Bu</td>
<td>Full moon</td>
<td>moon</td>
<td>B</td>
<td></td>
<td></td>
</tr>
<tr>
<td>2455763.60907</td>
<td>2011 JUL 3 3.65</td>
<td>0</td>
<td>Visual</td>
<td>MDP</td>
<td>Good</td>
<td>3.7</td>
<td>3.4</td>
<td>10star</td>
<td>Bu</td>
<td>Moon</td>
<td>Moon</td>
<td>B</td>
<td></td>
<td></td>
</tr>
<tr>
<td>2455767.76667</td>
<td>2011 JUL 3 3.65</td>
<td>0</td>
<td>Visual</td>
<td>MDP</td>
<td>Good</td>
<td>3.7</td>
<td>3.4</td>
<td>10star</td>
<td>Bu</td>
<td>Moon</td>
<td>Moon</td>
<td>B</td>
<td></td>
<td></td>
</tr>
<tr>
<td>2455780.82153</td>
<td>2011 JUL 4 4.2</td>
<td>0</td>
<td>Visual</td>
<td>MDP</td>
<td>Good</td>
<td>3.7</td>
<td>4.4</td>
<td>10star</td>
<td>Bu</td>
<td>Moon</td>
<td>Moon</td>
<td>B</td>
<td></td>
<td></td>
</tr>
<tr>
<td>2455813.58333</td>
<td>2011 SEP 3 3.35</td>
<td>0</td>
<td>Visual</td>
<td>MDP</td>
<td>Good</td>
<td>34</td>
<td>37</td>
<td>10starBU</td>
<td>close to moon</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>2455814.36</td>
<td>2011 SEP 3 3.6</td>
<td>0</td>
<td>Visual</td>
<td>MDP</td>
<td>Good</td>
<td>34</td>
<td>3.7</td>
<td>10star</td>
<td>B</td>
<td>Full moon</td>
<td>Full moon</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>2455816.6375</td>
<td>2011 SEP 4 4.2</td>
<td>0</td>
<td>Visual</td>
<td>MDP</td>
<td>Good</td>
<td>3.7</td>
<td>4.4</td>
<td>10star</td>
<td>B</td>
<td>Full moon</td>
<td>Full moon</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>2455818.65129</td>
<td>2011 SEP 4 4.6</td>
<td>0</td>
<td>Visual</td>
<td>MDP</td>
<td>Good</td>
<td>4.4</td>
<td>4.7</td>
<td></td>
<td>not sure</td>
<td>B</td>
<td>Moon</td>
<td>Moon</td>
<td></td>
<td></td>
</tr>
<tr>
<td>2455835.54444</td>
<td>2011 OCT</td>
<td>3.4</td>
<td>Visual</td>
<td>KJMA</td>
<td>Good</td>
<td>32</td>
<td>37</td>
<td>Star Train</td>
<td>B</td>
<td>Clear</td>
<td>Clear</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>2455836.51389</td>
<td>2011 OCT</td>
<td>3.65</td>
<td>Visual</td>
<td>MDP</td>
<td>Good</td>
<td>3.7</td>
<td>3.4</td>
<td>10star</td>
<td>B</td>
<td>Moon</td>
<td>Moon</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>2455837.13542</td>
<td>2011 OCT</td>
<td>3.3</td>
<td>Visual</td>
<td>KJMA</td>
<td>Good</td>
<td>32</td>
<td>34</td>
<td>Star Train</td>
<td>B</td>
<td>Clear</td>
<td>Clear</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>2455838.12153</td>
<td>2011 OCT</td>
<td>4.2</td>
<td>Visual</td>
<td>KJMA</td>
<td>Good</td>
<td>37</td>
<td>44</td>
<td>Star Train</td>
<td>B</td>
<td>Clear</td>
<td>Clear</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>2455839.64861</td>
<td>2011 OCT</td>
<td>4.45</td>
<td>Visual</td>
<td>MDP</td>
<td>Good</td>
<td>44</td>
<td>47</td>
<td>10staroth</td>
<td>B</td>
<td>Moon</td>
<td>Moon</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>2455840.60417</td>
<td>2011 OCT</td>
<td>4.55</td>
<td>Visual</td>
<td>MDP</td>
<td>Good</td>
<td>4.7</td>
<td>4.7</td>
<td>10starstar</td>
<td>B</td>
<td>Moon</td>
<td>Moon</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>2455842.65417</td>
<td>2011 OCT</td>
<td>3.6</td>
<td>Visual</td>
<td>MDP</td>
<td>Good</td>
<td>34</td>
<td>37</td>
<td>10star</td>
<td>B</td>
<td>Moon</td>
<td>Moon</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>2455850.69097</td>
<td>2011 OCT</td>
<td>3.6</td>
<td>Visual</td>
<td>EJDA</td>
<td>Good</td>
<td>37</td>
<td>34</td>
<td>10 star</td>
<td>B</td>
<td>Moon</td>
<td>Moon</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>2455867.51736</td>
<td>2011 NOV</td>
<td>3.4</td>
<td>Visual</td>
<td>MDP</td>
<td>Good</td>
<td>37</td>
<td>44</td>
<td>10star</td>
<td>B</td>
<td>Moon</td>
<td>Moon</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>2455871.51002</td>
<td>2011 NOV</td>
<td>3.65</td>
<td>Visual</td>
<td>MDP</td>
<td>Good</td>
<td>34</td>
<td>37</td>
<td>10star</td>
<td>B</td>
<td>Moon</td>
<td>Moon</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>2455899.46736</td>
<td>2011 DEC</td>
<td>3.65</td>
<td>Visual</td>
<td>MDP</td>
<td>Good</td>
<td>37</td>
<td>44</td>
<td>10star</td>
<td>B</td>
<td>Moon</td>
<td>Moon</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>2456013.57797</td>
<td>2012 JUL 4</td>
<td>1.2</td>
<td>Visual</td>
<td>MDP</td>
<td>Good</td>
<td>37</td>
<td>44</td>
<td>10star</td>
<td>B</td>
<td>Moon</td>
<td>Moon</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>2456013.71667</td>
<td>2012 JUL 5</td>
<td>4.2</td>
<td>Visual</td>
<td>MDP</td>
<td>Good</td>
<td>37</td>
<td>44</td>
<td>10star</td>
<td>B</td>
<td>Moon</td>
<td>Moon</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>2456014.72292</td>
<td>2012 JUL 6</td>
<td>3.65</td>
<td>Visual</td>
<td>MDP</td>
<td>Good</td>
<td>37</td>
<td>44</td>
<td>10star</td>
<td>B</td>
<td>Moon</td>
<td>Moon</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>2456014.4937</td>
<td>2012 JUL 7</td>
<td>3.5</td>
<td>Visual</td>
<td>MDP</td>
<td>Good</td>
<td>44</td>
<td>37</td>
<td>10star</td>
<td>B</td>
<td>Moon</td>
<td>Moon</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>2456014.5109</td>
<td>2012 JUL 8</td>
<td>3.5</td>
<td>Visual</td>
<td>MDP</td>
<td>Good</td>
<td>44</td>
<td>37</td>
<td>10star</td>
<td>B</td>
<td>Moon</td>
<td>Moon</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>2456016.44444</td>
<td>2012 JUL 10</td>
<td>3.5</td>
<td>Visual</td>
<td>MDP</td>
<td>Good</td>
<td>44</td>
<td>37</td>
<td>10star</td>
<td>B</td>
<td>Moon</td>
<td>Moon</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>2456017.2826</td>
<td>2012 JUL 12</td>
<td>3.5</td>
<td>Visual</td>
<td>MDP</td>
<td>Good</td>
<td>44</td>
<td>37</td>
<td>10star</td>
<td>B</td>
<td>Moon</td>
<td>Moon</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>2456018.54972</td>
<td>2012 SEP</td>
<td>3.35</td>
<td>Visual</td>
<td>MDP</td>
<td>Good</td>
<td>44</td>
<td>37</td>
<td>10star</td>
<td>B</td>
<td>Moon</td>
<td>Moon</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>2456025.87986</td>
<td>2013 APR</td>
<td>3.45</td>
<td>Visual</td>
<td>MDP</td>
<td>Good</td>
<td>44</td>
<td>37</td>
<td>10star</td>
<td>B</td>
<td>Moon</td>
<td>Moon</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>2456040.88194</td>
<td>2013 APR</td>
<td>3.35</td>
<td>Visual</td>
<td>MDP</td>
<td>Good</td>
<td>44</td>
<td>37</td>
<td>10star</td>
<td>B</td>
<td>Moon</td>
<td>Moon</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>2456049.67778</td>
<td>2013 JUL</td>
<td>4.5</td>
<td>Visual</td>
<td>MDP</td>
<td>Good</td>
<td>44</td>
<td>37</td>
<td>10star</td>
<td>B</td>
<td>Moon</td>
<td>Moon</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>2456049.8765</td>
<td>2013 JUL</td>
<td>3.95</td>
<td>Visual</td>
<td>MDP</td>
<td>Good</td>
<td>44</td>
<td>37</td>
<td>10star</td>
<td>B</td>
<td>Moon</td>
<td>Moon</td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
Rather than asking VStar to match across all columns, a particular column can be targeted, as in the following example that looks for observations whose Calendar Date column matches “2011 OCT 31” or “2013 APR 23” via the pattern 2011 OCT 31|2013 APR 23 where the vertical bar character (|) means “or” or “alternatively”.

The following shows the result of applying the pattern ^\d{2}$ to the Comp Star 2 column so that only those observations whose second comparison star consists of 2 digits will be shown:
The caret (“^”) means “start of string”, dollar (“$”) means “end of string”, “\d” means decimal digit characters (0 to 9), “\{2\}” means two of those (digit characters). This reduces to: “comp star 2 must only consist of 2 decimal digits to be included in the observation list.”

Regular expressions can be simple strings or extremely complex patterns, but a VStar user need not be troubled by using anything more complex than he or she requires.

A complete treatment of regular expressions is beyond the scope of this document. See Regular Expressions subsection in References and Further Reading.

A search will disrupt the synchronization between plot and list, as will clicking the Reset button.

There is a second radio button in the Search pane: VeLa Expression. Selecting this allows a VeLa expression to be entered. The following example shows the results of a VeLa based search for only those V or B and CCD or DSLR observations with a magnitude of more than 3.7 and uncertainty of less than 0.02:

\[
\text{mag} > 3.7 \text{ and uncertainty < 0.02 and band in ["Johnson V" "Johnson B"] and}
\]
obstype in ["CCD" "DSLR"]

See also Filtering Observations.

If one or more observations are selected in the list by single-clicking, shift-clicking, or ctrl-clicking, those observations may:

- be excluded via Edit → Exclude Selection;
- form the basis of an observation filter via the Create Selection Filter button.

See the Filtering Observations section for more information.

Note that the Select All button is useful for selecting all observations currently in view in order to create a selection filter or exclude observations.

Each Observation List row also contains a Discrepant? checkbox indicating whether an observation is “discrepant” and permitting an observation to be reported as discrepant. See the Observation Details Dialog section for details.
The contents of the Observation List can be saved to a file or printed via the File menu’s Save... and Print... items, or the corresponding toolbar buttons.

An example of the Save Dialog is shown below.

In the example above, when the Save button is clicked, the current Observation List will be saved to a file called “omiCetLC.tsv”.

Files can be saved as rows of values separated by delimiters such as tabs, commas, or spaces. The first two are preferable over the last since spaces in some fields lead to ambiguity if loading back into VStar or other software is required. From experience, tabs are less frequent, compared to commas, in fields such as comments (as found in AAVSO download files), so tab separation is a good choice.

The file created when saving observations is in the download format by default. To reload a file saved in this format into VStar at a later time, use New Star from File... You might find it useful after doing additive loads from several sources to save the set of observations to a file for future work. Be sure to make sure the set of observations you want to save are visible in the observations list. Only these will be saved.
Note that if phase plot mode is enabled, a saved file will have an additional (phase) column prepended, and will not be directly reloadable.

The Print Dialog looks like this on a Mac OS X machine:
Observation Details Dialog

The details of an individual observation can be viewed by selecting an observation in the Plot pane such that the cross hair is upon it, e.g.

Light Curve for R Car

Selecting a row in the observation list is equivalent to this, e.g.

The observation details dialog is invoked from the View menu or via the corresponding toolbar button:
The observation in this example was a visual estimate of R Car made by the author:
If a phase plot has been created, the phase will also be shown. If the time is a Heliocentric Julian Date rather a Julian Date, this will be indicated. Other details will differ depending upon the kind of observation (e.g. visual vs photometric), the observer, comment codes, band, and so on.

Note that the same information is available in the Observation List; however it can be useful to have multiple observation details dialogs open simultaneously, especially when observations are separated widely in time.

Selecting the Discrepant? checkbox relegates the observation to the discrepant series. This can be made visible on the plot via the Plot Control Dialog. If the dataset was loaded from the AID, another dialog will be opened, asking whether to submit a discrepant report to AAVSO HQ, e.g.
Of course, this particular observation is fine and no discrepant report was actually submitted. Before the observation report is sent, you will be asked to authenticate with your AAVSO web credentials.

This same Discrepant checkbox and reporting capability also exists in each Observation List row.

To find out more about the criteria for reporting an observation as discrepant, see the Zapper tool's online help: http://www.aavso.org/sites/default/files/software/zapper/zapperhelp.pdf
Plot Control Dialog

Selecting the View → Plot Control... item:

![Plot Control Dialog](image)

opens the plot control dialog. The example below shows the Plot Control Dialog resulting from an AID load of R Car.
The dialog has a few distinct features:

- **Visibility checkboxes.** Toggling these immediately changes the series that are visible on the plot and in the observation list. **Select All** and **Deselect All** buttons make it easier to work with many series.

- **Mean series source radio buttons.** Selecting a radio button changes the series that is used to create a mean series. If the mean series is not already visible, changing this selection makes it so. A mean series source change is acted upon immediately.

- **Checkboxes for:**
  - showing/hiding error bars;
  - showing/hiding cross-hairs;
  - inverting the range axis.

2 Note that for the mean series, error bars denote 95% Confidence Interval (twice Standard Error).
• Binned mean series update:
  ○ Checkbox to join mean data points.
  ○ Spinner and text-box for number of days or phase steps per bin. The Apply button must be clicked for a change to this value to be acted upon.

The first two sections vary according to the number of series in the currently loaded dataset.

If the Means checkbox is selected as follows:

![Screenshot of Light Curve Control interface]

the resulting plot will look somewhat like this, depending upon JD range loaded:
When in Phase Plot view mode, the Mean Series Update section changes to refer to Phase steps per Mean Series bin instead of Days per Mean Series bin as shown below.

The resulting phase plot (after clicking Apply) would look somewhat like this:
Phase Plot for R Car
26/04/2020 (database), period: 307, epoch: 2454597

Brightness (magnitude)

Phase

-1.0 -0.9 -0.8 -0.7 -0.6 -0.5 -0.4 -0.3 -0.2 -0.1 0.0 0.1 0.2 0.3 0.4 0.5 0.6 0.7 0.8 0.9 1.0

-10.25 -9.75 -9.25 -8.75 -8.25 -7.75 -7.25 -6.75 -6.25 -5.75 -5.25 -4.75 -4.25

-10.00 -9.50 -9.00 -8.50 -8.00 -7.50 -7.00 -6.50 -6.00 -5.50 -5.00 -4.50 -4.00 -3.50 -3.00 -2.50 -2.00 -1.50 -1.00 -0.50 0.00 0.50 1.00

• Johnson V • Visual • Means
Information Dialog

Selecting File → Info... invokes the Information Dialog for the currently loaded dataset or from the corresponding toolbar button.

Here is an example Information Dialog for 2 years of R Car data:

Source Type: AAVSO International Database observation source
Source Name: R Car; loaded: Tue Apr 14 17:50:28 ACST 2020
AUID: 000–BBQ–500
Period: 307 days
Epoch: 2454597
Variable Type: M
Spectral Type: M4e–M8e
RA (J2000): 143.06083 degrees
Dec (J2000): –62.78889 degrees

Series
Loaded Observations: 365
Johnson B: 1
Johnson V: 2
Tri–Color Green: 7
Visual: 355
The dialog is divided into Summary and Series sections.

The Summary section includes information about the source of the dataset, AAVSO Unique ID (AUID), and if known, period, epoch, variable type, spectral type, and coordinates. For an AID loaded dataset like this VSX is consulted for such information.

For an observation source other than AID (e.g. AAVSO upload or download files, ASAS, Kepler), VSX is not consulted so the summary information will be different. Here is an example of an Information Dialog for ASAS R Car data:

The Series section lists all series present in the dataset (e.g. the filter band or visual observations) along with the number of observations in each series.
Filtering Observations

It is often useful to work with a subset of the data based upon criteria other than the series in which the data resides, e.g. magnitude or time range, observer code, or some combination.

VStar has four mechanisms by which to create a filtered subset:

- The simple observation filter dialog (View → Simple Filter...).
- Creation of a filter from the current plot view (View → Filter From Plot).
- An Observation List selection filter (Create Selection Filter button).
- The VeLa filter dialog (View → VeLa Filter...).
- Custom observation filter plug-ins.

Consider the following W UMa observations:

Notice that the cross-hairs are on an observation at the leftmost time extent of a particular block of Johnson V observations.
Selecting **View → Simple Filter...** or the corresponding toolbar button opens the Observation Filter Dialog.
Here, “Use selected observation” has been checked such that when JD (Julian Day) is selected from a drop-down field menu, the text box is populated with the JD of the selected observation (under the cross-hairs). Selecting “greater than or equal” from the middle drop-down menu then dismissing the dialog with the OK button yields the following:
Notice that all observations with JDs greater than or equal to the selected observation are shown as being in the Filtered series (see legend at bottom of plot), regardless of series.

This filter could be refined to restrict the JD range and series included. The following example creates a filtered subset of observations where the JD is greater than or equal to 2454880 and the JD is less than or equal to 2454930, and the band is Johnson V. Operators differ with field type:

- For numeric fields such as JD, magnitude, and error, the usual relational operators are provided (equal, not equal, less than, greater than, less than or equal, greater than or equal).
- For string fields such as observer code or object name, equal and not equal are permitted.

The constrained filter mentioned above and the resulting observation plot are shown below.

Notice the implicit “AND”s represented by the filter dialog selections. Currently, 8 such “conjunctive” terms are permitted in a single filter. For example:
Note that the “Filter Name” text box at the top of the observation filter dialog can be modified to give a filter a meaningful name, e.g. “2454880...2454930 V.”

A filter series can be hidden from view just like any other series, via the Plot Control Dialog. The current filter can be completely removed by selecting View → No Filter.

Previously created filters for the currently loaded dataset can be retrieved and viewed by selecting View → Previous Filters...

Filters can also be deleted and new series can be created from them, to be treated just like any other series in the Plot Control Dialog, preferences and so on. Each filter has a description that can be viewed via the Show Description button.
The second method of creating an observation filter is via an Observation List selection filter.

The following observation list screenshot shows a pattern search (see Observation List section) being used to narrow down observations to just Johnson V (this could also have been done via the Plot Control dialog) and a selection (via shift + mouse-click) of multiple observations.

Note that VeLa filter expressions can be used here instead of regular expressions. See the Observation List section.

Clicking the Create Selection Filter button would yield the same filtered subset as above (assuming the end date was appropriately selected). Note that the Select All button is useful for selecting all observations currently in view in order to create a selection filter.
Selecting **View → Filter From Plot** creates a filter from the observations currently visible in the raw mode plot.
Selecting View → VeLa Filter... opens the VeLa (see Glossary) filter dialog. The figure below shows a VeLa filter that creates an R Car observation subset conforming to the filter expression shown: transformed V or B observations with a time greater than 2457600 and any observer code other than the author's:
A drop-down menu provides a list of possible observation properties.

Note that descriptions in the Previous Filters dialog for simple and selection filters are also VeLa expressions so may be used as the starting point for more complex VeLa filters.

For more information about the VeLa language, see https://github.com/AAVSO/VStar/wiki/VeLa

See the Plug-ins section for details of custom filters, also available in the View menu.
Phase Plots

The Period Analysis section details how VStar can be used to analyze a dataset for candidate periods (the time taken for a star’s variability to complete one full cycle). If a star is assumed to have a particular period, VStar can be asked to create a so-called phase plot or folded light curve, in which all observations are plotted into a “window” of a particular size: the period in days.

\[ \phi = \frac{t - \text{epoch}}{P} \]

To accomplish this, each observation’s time is converted to a phase according to the following equation:

where \( \phi \) is the phase, \( t \) is the observation time, \( \text{epoch} \) is some initial time, and \( P \) is the assumed period. The \( \text{epoch} \) can be one of a number of values from the current dataset, such as the time of the first observation, the time closest to the mid-point, the mean of the first and last time, a time of minimum or maximum. The most appropriate \( \text{epoch} \) to use may depend upon the variable type. If one is not available from VSX for the star (and only for an AID loaded dataset), the default epoch computed by VStar is the mean of the first and last time in the current dataset.

Assume the following eta Aquilae dataset is loaded:
Using the period and epoch for eta Aquilae shown on VSX (http://www.aavso.org/vsx/index.php?view=detail.top&oid=2802), the following phase plot can be created:
To create a phase plot like this one, select Analysis → Phase Plot...

yielding the phase plot parameter dialog and click OK to create the phase plot:
If a dataset is loaded from AID, VStar will retrieve this information from VSX and populate the phase plot parameter dialog text fields.

A phase plot for which the specified period is incorrect compared to the actual period, results in a “messy” (or out of phase) plot. For example, here is eta Aquilae with a phase plot using a period of 7.5 days instead of 7.176641 days:
The Analysis menu’s Previous Phase Plots... item yields a dialog that permits previously created phase plots to be selected or deleted, e.g.

The first two items in the View menu allow you to switch between phase plot and raw view.
modes. There are corresponding toolbar buttons.

If no phase plot exists the first time Phase Plot view mode is selected, the phase plot parameter dialog will be invoked.

Here is another example that demonstrates the visualization power of a phase plot given the right period. The following shows a dataset loaded via the Kepler observation source plug-in:

As described in detail elsewhere (http://dbenn.wordpress.com/2013/03/29/obtaining-and-analysing-kepler-data-with-vstar), the following phase plot reveals the nature of the star as an RR Lyr star variable (RRAB) with a period of around 0.48 days:
By default, observation rows are still sorted by JD, but clicking the Phase column will order by phase.

The Period Analysis section shows how to create a phase plot from the result dialog of a period search. See also the Further Reading section.
Period Analysis

Introduction
The purpose of period analysis is, as the term suggests, to identify candidate periods for a variable star from the available data. There are a number of ways to do this. Sometimes, one can simply inspect the light curve to find the time taken for the brightness change to go through one full cycle. For less obvious cases, an algorithm such as AoV, PDM, or Fourier analysis can be used to search for candidate periods.

VStar implements the Date Compensated Discrete Fourier Transform (DCDFT) algorithm (Ferraz-Mello 1981), yielding a power spectrum and a table of “top-hits” given a specified series, frequency (or period) range, and resolution. The “date compensated” part of the name indicates that gaps in the data, common for variable star observations, are compensated for by the algorithm.

From within the DCDFT result window, a phase plot can be created (see Phase Plots section for more information). In addition, one or more periods each with one or more harmonics can be selected to create a model. A model’s Fourier coefficients can be viewed along with relative amplitudes and phases.

Optionally, multiple periods found by DCDFT can subsequently be refined via the CLEANest (Foster 1995) algorithm.

When a model is created, it is also subtracted from observations in the series on which the DCDFT was performed to yield a second, “residuals,” series. DCDFT can then be applied to these residuals to look for further signals (periods), a process often called “pre-whitening.”

The following shows eta Aquilae data from AAVSO International Database (AID) in the JD range 2455695.8431 to 2456419.8604, a DCDFT “power spectrum”, and a phase plot resulting from a top-hit selection.
DCDFT in Detail

DCDFT menu items are available in the Analysis menu. As shown below, the options are DCDFT standard scan, DCDFT with frequency range, or with period range.

Looking at the eta Aql example above in more detail, selecting DCDFT Standard Scan... yields the series selection dialog, since period search is only applied to a single series:
Here, the **Visual** series is selected. Clicking the **OK** button leads, after a short time, to the result dialog:
By default, the Power vs Frequency plot (sometimes called the “power spectrum”) is shown. Notice that Show top hits? is checked here, again, by default. The small brightly colored squares correspond to “top hits,” those frequencies/periods at the peaks of the plot (those with highest power value). These are the best candidates for the actual frequency (period).

As with all plots in VStar, zooming in to a DCDFT plot can be done by click-dragging a rectangular area of the plot or using the context menu (e.g. via right-click in Windows or ctrl-click on Mac OS X) Zoom In/Out items, as was done for the power spectrum shown in the Introduction section.

Before leaving this tab, notice the Logarithmic? checkbox. If selected, the power (or semi-amplitude in the case of the Semi-amplitude vs Frequency plot) axis will become a base-10 log scale. This can sometimes help to reveal frequencies of interest.
Selecting the Top Hits tab shows the top hits, referred to above, in tabular form.

<table>
<thead>
<tr>
<th>Frequency</th>
<th>Period</th>
<th>Power</th>
<th>Amplitude</th>
</tr>
</thead>
<tbody>
<tr>
<td>0.107610</td>
<td>2.39033</td>
<td>1.77087</td>
<td>4.3105793347004</td>
</tr>
<tr>
<td>0.141781</td>
<td>3.58519</td>
<td>1.79531174650</td>
<td>0.19552786</td>
</tr>
<tr>
<td>0.136790</td>
<td>3.71099454</td>
<td>1.71182975425637</td>
<td>0.19041868</td>
</tr>
<tr>
<td>0.278925</td>
<td>3.58519</td>
<td>6.03003726017281</td>
<td>0.11155846</td>
</tr>
<tr>
<td>0.276245</td>
<td>3.62008217</td>
<td>2.92991150600289</td>
<td>0.07826145</td>
</tr>
<tr>
<td>0.281223</td>
<td>3.55589244</td>
<td>24.4393168000521</td>
<td>0.07189908</td>
</tr>
<tr>
<td>0.134802</td>
<td>7.45721</td>
<td>20.68094814000521</td>
<td>0.06493511</td>
</tr>
<tr>
<td>0.144443</td>
<td>6.92314337</td>
<td>17.99564602000521</td>
<td>0.06098598</td>
</tr>
<tr>
<td>0.418365</td>
<td>2.39033</td>
<td>12.32966424000521</td>
<td>0.05127045</td>
</tr>
<tr>
<td>0.105362</td>
<td>9.48400016</td>
<td>9.81780191000521</td>
<td>0.04253121</td>
</tr>
<tr>
<td>0.068517</td>
<td>14.58114554</td>
<td>9.59572999000521</td>
<td>0.04426406</td>
</tr>
<tr>
<td>0.103064</td>
<td>9.70269456</td>
<td>9.42094550000521</td>
<td>0.04461421</td>
</tr>
<tr>
<td>0.420686</td>
<td>2.78707290</td>
<td>8.48601520000521</td>
<td>0.04242292</td>
</tr>
<tr>
<td>0.149423</td>
<td>6.69237193</td>
<td>7.59515644000521</td>
<td>0.04047890</td>
</tr>
<tr>
<td>0.581857</td>
<td>1.71825217</td>
<td>7.38483884000521</td>
<td>0.03921081</td>
</tr>
<tr>
<td>0.175803</td>
<td>5.88632909</td>
<td>7.05278187000521</td>
<td>0.03813793</td>
</tr>
<tr>
<td>0.415704</td>
<td>2.40555104</td>
<td>6.34992066000521</td>
<td>0.03621076</td>
</tr>
<tr>
<td>0.173178</td>
<td>5.77439171</td>
<td>5.66317097000521</td>
<td>0.03427980</td>
</tr>
<tr>
<td>0.039432</td>
<td>25.34004905</td>
<td>5.47302860000521</td>
<td>0.03343941</td>
</tr>
<tr>
<td>0.036712</td>
<td>27.18776096</td>
<td>5.21778103000521</td>
<td>0.03358764</td>
</tr>
<tr>
<td>0.010727</td>
<td>93.21518043</td>
<td>4.95850751000521</td>
<td>0.03269315</td>
</tr>
<tr>
<td>0.273560</td>
<td>3.65349727</td>
<td>4.78728188000521</td>
<td>0.03193053</td>
</tr>
<tr>
<td>0.107618</td>
<td>9.28835458</td>
<td>4.76483946000521</td>
<td>0.03174936</td>
</tr>
<tr>
<td>0.584285</td>
<td>1.71149184</td>
<td>4.65395022000521</td>
<td>0.03087283</td>
</tr>
<tr>
<td>0.383904</td>
<td>2.60481541</td>
<td>4.60280399000521</td>
<td>0.03078519</td>
</tr>
</tbody>
</table>

Clicking the New Phase Plot button with the shown top-hit selected will result in the phase seen earlier in this section.

Harmonics

The Find Harmonics button will show a list of harmonics of the main frequency (or period which is:

$$\frac{1}{\text{frequency}}$$

in the data. VStar adopts the convention (from Foster 2010) that the first harmonic is the fundamental frequency. This can be used as a decision support aid for model creation.
Creating Fourier Series Models

The Create Model button creates a Fourier series from the selected period and one or more harmonics selected from the following dialog. In this case, 4 harmonics are selected, which is to say, the fundamental and the next 3 harmonics.

Clicking OK gives the following if phase plot mode is selected:
or the following if VStar is in raw data mode, by means of contrast immediately revealing the allure of the combination of period analysis, phase plots and models:
Previous models can be revisited via the models dialog, invoked by Analysis → Models...

Models can be deleted or selected for plotting or inspection. Clicking the Show Model button opens a dialog that shows the selected model function in different forms.

The model equations can be selected and copied with the mouse (via manual selection or select-all/copy keyboard shortcuts) and used as part of a script. For example, from the dialog above, the R Fourier series equation:
model <- function(t) 3.90735950 +
0.22801206 * cos(2*pi*0.13946226*(t-2455968.0))+0.18642782
* sin(2*pi*0.13946226*(t-2455968.0))+
-0.09565610 * cos(2*pi*0.27892453*(t-2455968.0))+0.03678474
* sin(2*pi*0.27892453*(t-2455968.0))+
0.01725381 * cos(2*pi*0.41838679*(t-2455968.0))-0.02887188
* sin(2*pi*0.41838679*(t-2455968.0))+
0.00455999 * cos(2*pi*0.55784905*(t-2455968.0))-0.00786789
* sin(2*pi*0.55784905*(t-2455968.0))

can be used in conjunction with observations, model data and the script available at the following location to plot the model equation:


For a more comprehensive R based tool, see Maksym Pyatnytskyy's VStarModelPlot:

[https://github.com/mpyat2/VStarModelPlot](https://github.com/mpyat2/VStarModelPlot)

The Excel formula should be copied and pasted into a text editor and linefeeds removed before pasting into Excel.

In the presence of a model with harmonics, the model information dialog will include a pane titled Relative Amplitudes & Phases by fundamental frequency. This is a standard way of describing the shape of a waveform, especially for pulsating stars with close-to-perfect periodicity. For more information about this, see Foster (2010).

Having created a model, looking at the residuals series can provide information about any remaining signal (e.g. via binned means; see also Current Mode ANOVA plug-in). The residuals series can, like any other series, have DCDFT applied to it to search for additional periods.

**Other DCDFT options: Period and Frequency Range**

Up to this point, only the DCDFT standard scan has been mentioned. As can be seen from the Analysis menu, DCDFT with frequency range and period range are also available.

VStar’s DCDFT Java implementation is a direct translation of AAVSO’s TS program. The following is adapted from the documentation accompanying the Fortran TS implementation.
created by Matthew Templeton, which in turn was translated from a BASIC implementation by
Grant Foster (see References section):

\[
\frac{1}{4T}
\]

The simplest choice is DCDFT Standard Scan. The smallest frequency (longest period)
tested by the standard scan is \( \frac{1}{4T} \), where \( T \) is the total time span of the data. The standard scan will
test frequencies from:

\[
\frac{1}{4T}
\]

to:

\[
\frac{N}{4T}
\]

where \( N \) is the number of data, in steps of:

\[
\frac{1}{4T}
\]

Because VStar utilizes a discrete form of the Fourier transform, the computation time will
increase as the square of the number of data points. For 100,000 data points or more, consider
averaging or filtering the data points prior to processing.

As it tests each frequency, VStar records the frequency, period, and power. Frequencies with the
highest power levels are the most likely possibilities for the actual frequency of a periodic
fluctuation in the data (if it has one; after all, not all data are periodic). VStar keeps a record of
the top (highest power) 100 frequencies/periods (see Top Hits pane in the DCDFT result
dialog).

To specify a range of frequencies or periods to test, choose option the DCDFT with
Frequency Range or DCDFT with Period Range options. VStar requests the low
frequency or period to test, the high frequency or period, and for the resolution. The resolution
is the spacing between test frequencies or periods. For instance, to test a range of periods, from
as low as 100 days to as high as 150 days, if a resolution of 1 is specified, VStar will test all
periods from 100 to 150 in 1-day steps.

Note that non-zero values must be entered in the parameter dialog. The following figure shows
an example of the parameter dialog for the scenario described above:
The DCDFT with Frequency Range option populates the dialog with an initial frequency range and resolution as described for Standard Scan above.

**CLEANest**

The TS documentation cited above goes on to make the following comment:

*When you run a Fourier analysis of the data, it is possible that the "peak" signal or signals you detect may not be the precise frequency actually detected in the data set, because the sampled frequencies tested might be offset slightly from the true signals.*

Like TS, VStar is capable of refining one or more periods simultaneously via the CLEANest (Foster 1995) algorithm.

Grant Foster’s 1995 CLEANest Fourier Spectrum paper (Foster 1995) gives a number of examples of applying the CLEANest algorithm to datasets, artificial and real. Two of these use AAVSO visual magnitude estimates: S Ori and AA Cas.

What follows will show VStar’s CLEANest implementation applied to AA Cas. Foster (1995) uses an AA Cas dataset in the JD range 2447500 to 2449500. Here is that dataset loaded from the AAVSO International Database (AID):
A DCDFT with frequency range can be initiated from VStar’s Analysis menu, selecting the Visual band and specifying minimum and maximum frequencies, the range over which to scan (0.0001 to 0.02), and frequency resolution (0.000001) over the range.

This results in the following power spectrum (in the Power vs Frequency pane) with the orange squares showing peaks or “top hits”.

![Light Curve for AA Cas](image)
These top hits are shown in the next diagram in tabular form.

Notice that seven top hits are shown as being selected using combinations of shift-click and control-click (Windows) or command-click (Mac). The initial input values to CLEANest are not stated in Foster (1995; section 5, page 1900), but the rows selected above fairly closely correspond to what the paper presents.
Clicking the `CLEANest` button from the Top Hits pane opens this dialog.
Clicking OK here adds seven new top hits with the same power value, shown multiply-selected in the top hits list and annotated on the power spectrum.
<table>
<thead>
<tr>
<th>Frequency</th>
<th>Period</th>
<th>Power</th>
<th>Semi-amplitude</th>
</tr>
</thead>
<tbody>
<tr>
<td>0.012461059</td>
<td>80.25</td>
<td>155.037000753</td>
<td>0.009028042</td>
</tr>
<tr>
<td>0.01312336</td>
<td>76.2</td>
<td>155.037000753</td>
<td>0.009028042</td>
</tr>
<tr>
<td>0.002645503</td>
<td>378</td>
<td>155.037000753</td>
<td>0.009028042</td>
</tr>
<tr>
<td>0.008257638</td>
<td>121.1</td>
<td>155.037000753</td>
<td>0.009028042</td>
</tr>
<tr>
<td>0.00078125</td>
<td>1280</td>
<td>155.037000753</td>
<td>0.009028042</td>
</tr>
<tr>
<td>0.013908206</td>
<td>71.9</td>
<td>155.037000753</td>
<td>0.009028042</td>
</tr>
<tr>
<td>0.001538462</td>
<td>650</td>
<td>155.037000753</td>
<td>0.009028042</td>
</tr>
<tr>
<td>0.012514</td>
<td>79.91050024</td>
<td>52.495079545</td>
<td>0.13555936</td>
</tr>
<tr>
<td>0.013908</td>
<td>71.901064136</td>
<td>30.551808157</td>
<td>0.104391456</td>
</tr>
<tr>
<td>0.002607</td>
<td>383.582662064</td>
<td>16.643837173</td>
<td>0.075596531</td>
</tr>
<tr>
<td>0.011181</td>
<td>89.437438512</td>
<td>10.653360906</td>
<td>0.060324716</td>
</tr>
<tr>
<td>0.008296</td>
<td>120.540019286</td>
<td>9.6735554</td>
<td>0.058148184</td>
</tr>
<tr>
<td>0.000777</td>
<td>1287.001287001</td>
<td>8.934353663</td>
<td>0.060142139</td>
</tr>
<tr>
<td>0.009465</td>
<td>105.652403592</td>
<td>7.359393398</td>
<td>0.051108778</td>
</tr>
<tr>
<td>0.001902</td>
<td>525.762355415</td>
<td>5.17392489</td>
<td>0.045287349</td>
</tr>
<tr>
<td>0.014962</td>
<td>66.835984494</td>
<td>4.597436295</td>
<td>0.040041078</td>
</tr>
<tr>
<td>0.005444</td>
<td>183.688464364</td>
<td>4.574532526</td>
<td>0.041101006</td>
</tr>
<tr>
<td>0.018663</td>
<td>53.581953598</td>
<td>3.97852523</td>
<td>0.038425266</td>
</tr>
<tr>
<td>0.010392</td>
<td>96.22786759</td>
<td>3.636942671</td>
<td>0.036228241</td>
</tr>
<tr>
<td>0.017077</td>
<td>58.558294782</td>
<td>3.580537292</td>
<td>0.037271244</td>
</tr>
<tr>
<td>0.001552</td>
<td>644.329896907</td>
<td>3.555129036</td>
<td>0.03797365</td>
</tr>
<tr>
<td>0.003663</td>
<td>273.000273</td>
<td>3.250101152</td>
<td>0.034045859</td>
</tr>
<tr>
<td>0.015932</td>
<td>62.766758725</td>
<td>3.100866602</td>
<td>0.033390745</td>
</tr>
<tr>
<td>0.004308</td>
<td>232.126276695</td>
<td>2.857132117</td>
<td>0.032070464</td>
</tr>
<tr>
<td>0.007124</td>
<td>140.370578327</td>
<td>1.948357065</td>
<td>0.026362159</td>
</tr>
</tbody>
</table>
Now click **Create Model** in the Top Hits pane and the following dialog will open.
Click OK and the main plot will have an additional “model” series added. Dismiss the main DCDFT dialog to return to the main VStar window.
The residuals for this model can be viewed by opening the Plot Control dialog from the View menu and setting it as shown, including changing the Days per Mean Series Bin (and clicking Apply).

Dismissing the dialog changes the plot to look like this:
The Current Mode ANOVA plug-in could be used to show that what is observed in the residuals is likely to be due to noise rather than due to the presence of a non-trivial signal.

For another example of using CLEANest in VStar, see the following:

Polynomial Fit

Just as a mean curve can be thought of as a model of a dataset that has a smoothing effect, a polynomial model can also be used as a smoothing mechanism to capture key aspects of a dataset without all the “rough edges.”

Suppose you want to determine the time of maximum for the following Mira maximum light curve segment.

One way to do this is by fitting a polynomial to the data and using that to determine what the time of maximum is. The relationship between a sequence of x (time) values and corresponding dependent y (magnitude) values can be modeled as an *nth order* polynomial.

\[ y = f(t) = \beta_0 + \beta_1 t + \beta_2 t^2 + \beta_3 t^3 + \ldots + \beta_n t^n \]

A polynomial model of degree *n* is defined as a function of time with the following form:

where \( t \) is time (e.g. Julian Date) and \( \beta_n \) is a *coefficient*. The sum of these coefficients multiplied by corresponding time values, each raised to a power (the number or index of the coefficient):
...n), creates a curve that approximates the data. Notice that $\beta_0$ is just $\beta_0 t^0$. The process through which the coefficients are determined is beyond the scope of this document. See References and Further Reading for more background information about polynomial models and data fitting.

The degree of the polynomial will have a bearing on the values of the minima or maxima (critical points or extrema) found since (roughly speaking) the higher the degree, the better the polynomial approximates the features of the data.

In VStar, a polynomial fit can be created via the Analysis → Polynomial Fit... menu item or the corresponding toolbar button.

Selecting one of these will result in a Series Selection Dialog being invoked
In this case, the Visual series is selected and clicking the OK button yields the polynomial degree dialog.

This is used to specify the number of degrees for the polynomial to be created, 7 in this case. Clicking the OK button creates the polynomial fit of the Visual series and adds a Model series as follows:

Foster (2010) discusses essentially the same example except that R (a statistical programming language) is used rather than VStar. The Model tab contains a list of the polynomial fit data.
points visible on the plot.

<table>
<thead>
<tr>
<th>Julian Day</th>
<th>Calendar Date</th>
<th>Magnitude</th>
</tr>
</thead>
<tbody>
<tr>
<td>2451460.076400</td>
<td>1999 OCT 8</td>
<td>5.011615</td>
</tr>
<tr>
<td>2451460.310000</td>
<td>1999 OCT 8</td>
<td>4.987632</td>
</tr>
<tr>
<td>2451460.400000</td>
<td>1999 OCT 8</td>
<td>4.978363</td>
</tr>
<tr>
<td>2451460.500000</td>
<td>1999 OCT 9</td>
<td>4.968048</td>
</tr>
<tr>
<td>2451460.533300</td>
<td>1999 OCT 9</td>
<td>4.964610</td>
</tr>
<tr>
<td>2451460.638900</td>
<td>1999 OCT 9</td>
<td>4.933693</td>
</tr>
<tr>
<td>2451460.700000</td>
<td>1999 OCT 9</td>
<td>4.947370</td>
</tr>
<tr>
<td>2451460.700700</td>
<td>1999 OCT 9</td>
<td>4.947297</td>
</tr>
<tr>
<td>2451461.048600</td>
<td>1999 OCT 9</td>
<td>4.911200</td>
</tr>
</tbody>
</table>

The Residuals tab contains a list of the residuals (observation minus model for each such pair of values) from the polynomial fit.

<table>
<thead>
<tr>
<th>Julian Day</th>
<th>Calendar Date</th>
<th>Magnitude</th>
</tr>
</thead>
<tbody>
<tr>
<td>2451460.076400</td>
<td>1999 OCT 8</td>
<td>-0.211615</td>
</tr>
<tr>
<td>2451460.310000</td>
<td>1999 OCT 8</td>
<td>0.412368</td>
</tr>
<tr>
<td>2451460.400000</td>
<td>1999 OCT 8</td>
<td>0.021637</td>
</tr>
<tr>
<td>2451460.500000</td>
<td>1999 OCT 9</td>
<td>0.031952</td>
</tr>
<tr>
<td>2451460.533300</td>
<td>1999 OCT 9</td>
<td>-0.364610</td>
</tr>
<tr>
<td>2451460.638900</td>
<td>1999 OCT 9</td>
<td>-0.058693</td>
</tr>
<tr>
<td>2451460.700000</td>
<td>1999 OCT 9</td>
<td>-0.047370</td>
</tr>
<tr>
<td>2451460.700700</td>
<td>1999 OCT 9</td>
<td>0.152703</td>
</tr>
</tbody>
</table>

This series can also be viewed on the Plot pane by selecting the Residuals series in the Plot Control Dialog series visibility checkboxes.
In addition, as shown above, if the Residuals mean series source radio button is selected and Days per Mean Series bin set to 2, as shown, the Plot Pane will look like this:
As for a model or residuals plot, mean plot data points can be viewed in tabular format in the Means list by selecting the corresponding tab, for example:

<table>
<thead>
<tr>
<th>Julian Day</th>
<th>Calendar Date</th>
<th>Mean Magnitude</th>
<th>Standard Error of the Average</th>
</tr>
</thead>
<tbody>
<tr>
<td>2451460.630790</td>
<td>1999 OCT 9</td>
<td>-0.044445</td>
<td>0.071520</td>
</tr>
<tr>
<td>2451462.708323</td>
<td>1999 OCT 11</td>
<td>0.114983</td>
<td>0.093679</td>
</tr>
<tr>
<td>2451464.458864</td>
<td>1999 OCT 12</td>
<td>-0.033523</td>
<td>0.041960</td>
</tr>
<tr>
<td>2451466.812405</td>
<td>1999 OCT 15</td>
<td>-0.009216</td>
<td>0.062839</td>
</tr>
<tr>
<td>2451468.737686</td>
<td>1999 OCT 17</td>
<td>-0.008915</td>
<td>0.039249</td>
</tr>
<tr>
<td>2451470.514332</td>
<td>1999 OCT 19</td>
<td>0.012571</td>
<td>0.037948</td>
</tr>
<tr>
<td>2451472.748873</td>
<td>1999 OCT 21</td>
<td>0.033468</td>
<td>0.028761</td>
</tr>
<tr>
<td>2451475.285429</td>
<td>1999 OCT 23</td>
<td>0.079523</td>
<td>0.015781</td>
</tr>
<tr>
<td>2451477.762800</td>
<td>1999 OCT 25</td>
<td>-0.005127</td>
<td>0.060773</td>
</tr>
<tr>
<td>2451479.431043</td>
<td>1999 OCT 27</td>
<td>-0.045181</td>
<td>0.042430</td>
</tr>
</tbody>
</table>

The Current Mode ANOVA plug-in could be used to show that there is no significant signal remaining, and that the fit is apparently a good one, since what is observed in the residuals is likely to be due to noise rather than the presence of a non-trivial signal.

Additional information about created models can be obtained via the Model Information dialog. This can be invoked from the Analysis menu’s Models... item:
A model can be deleted via the **Delete** button. The **Select** button is used to select the highlighted model in the list for viewing on the Plot Pane and the Model and Residuals lists.

Selecting the **Show Model** button invokes the following dialog:
The Model Information dialog gives:

- VeLa, Excel, R functions for the polynomial.
- The Root Mean Square (RMS) value for the fit.
- Akaike and Bayesian Information Criteria, goodness of fit measures (AIC, BIC).
- Where they can be determined, extrema (minimum and maximum magnitude and JD).

Note that some details of this list may change in future VStar versions, e.g. additional function representations, information criteria, extrema determination methods.

Notice that the VeLa, Excel and R functions reveal the polynomial degree in the number of coefficients as explained earlier in this section. Notice also that each time term has a Julian Date zero-point subtracted from it, reflecting the way in which the polynomial fit was created, in order to reduce the magnitude of values (and possible loss of precision) when higher powers are involved.

The R function can be used in conjunction with observations, model data and the script available at the following location to plot the model equation:


For a more comprehensive R based tool, see Maksym Pyatnytskyy’s VStarModelPlot:
A polynomial fit can also be useful to characterize the overall shape of some light curves. Take for example the following light curve for Nova Delphini 2013 (V0339 Del):

![Light Curve for V0339 Del](image)

A polynomial of degree 6 of the Visual series gives the following:
**Time-Frequency Analysis**

VStar provides time-frequency analysis functionality in the form of Weighted Wavelet Z-Transform (WWZ) (Foster 1996). The user specifies a series (e.g. Visual, Johnson V), a frequency or period range, and a resolution; the result is a visualization of how the period changes over time. This can be viewed as a 2D graph, a contour plot, a rotatable 3D graph, or in tabular form. Periods at particular points in time can be selected for phase plot creation. A detailed explanation of the statistical analysis techniques being utilized here is beyond the scope of this document. The interested reader is referred to Foster (2010) and *References and Further Reading*.

The following shows the period change for T UMi in the year range 1913 to 2009. Here the color represents the WWZ statistic, the strength of a periodicity, at a particular time. This example is discussed in Foster (2010).

This section explores WWZ via T UMi.

The T UMi dataset below, taken from the AAVSO International Database (AID), spans the JD range 2,420,000 to 2,455,000. Even a visual inspection suggests amplitude and possible period
Creating a phase plot with periods taken from DCDFT (Date Compensated Discrete Fourier Transform) in VStar does not result in an obviously "clean" fit over the time range, as evidenced by DCDFT high-power top-hits (via Analysis → DCDFT Standard Scan...):
WWZ helps to explain why. It is available via two Analysis menu items and a toolbar button.

The toolbar button corresponds to the WWZ with Period Range item of the Analysis menu.

Applying WWZ to the dataset requires selecting the series to be analyzed, then the following parameters:
- Minimum frequency or period.
- Maximum frequency or period.
- Frequency or period step: this is the resolution in the frequency domain.
- Decay: this is the wavelet window; smaller values yield better resolution of variation.
- Time divisions: this gives the time resolution, defined as:

\[
\frac{\text{JD}_{\text{max}} - \text{JD}_{\text{min}}}{\text{time divisions}}
\]

revealed by the extent of “vertical banding” in the contour plot (as we see in the first figure of this section).

For T UMi, selecting Analysis → WWZ with Period Range, selecting the Visual series and entering values of 100 days (min period), 500 days (max period), 1 day (period resolution), 0.001 (decay) and 200 (time divisions) for the above parameters, gives a plot of period vs time:
The contour plot at the start of this section adds the WWZ statistic to the Period vs Time plot above. The Result dialog provides a number of other plots and tables. One of these is a 3D plot that provides the same information as the contour plot but allows rotation in all axes.
The WWZ algorithm generates the following statistics for the specified series and frequency or period range and time resolution which VStar presents in plot or tabular form (adapted from the AAVSO Fortran WWZ implementation documentation):

- **Time**: The time being examined, in JD.
- **Frequency**: The frequency being tested, in cycles per time unit.
- **Period**: The corresponding period under test, in JD.
- **WWZ**: Value of the WWZ; this is approximately an F-statistic with Effective number of data and 2 degrees of freedom, and expected value 1. In short, it indicates whether or not there is a periodic fluctuation of the given frequency at the given time.
- **Semi-amplitude**: Weighted wavelet amplitude; if the signal is periodic at the frequency being tested, this gives the (real semi-) amplitude of the corresponding best-fit sinusoid.
- **Mean magnitude**: Mean apparent magnitude of the object at the corresponding time.
- **Effective number of data**: The effective number of data for the given time and frequency being tested.

The maximal WWZ table shows the points at which the WWZ statistic was maximal:
A phase plot can be created from a selected result table row or plot datapoint in the WWZ results dialog via the New Phase Plot button.
The AAVSO Fortran WWZ implementation’s documentation has a section on suggested parameter values, minimally adapted below:

The chosen frequency range should only cover the range of frequencies of astrophysical interest to reduce computation time. For Mira and Semiregular variables, choosing a frequency range between 0.0001 (P = 10000 days) and 0.02 (P = 50 days) with delta f of 0.00001 is reasonable, and should not oversample the frequency spectrum too severely. Be sure to choose frequency values that are physically relevant to the system you are studying, and to the data available.

The decay constant, c, defines the width of the wavelet "window". It defines the number of cycles of a given frequency f expected within the window. Smaller values of c will produce wider windows. Reasonable values of c are between 0.001 and 0.0125. Note that using small values of c will result in improved frequency resolution of variations, but will smear out temporal variations. Conversely, large values of c will improve the temporal resolution, but will generate larger uncertainties in peak frequency.

WWZ scans the data set starting from the earliest data and progressing to the latest. If you notice that the program returns zero values of the WWZ statistic, then you probably have a large
data gap just prior to the point where the zero values begin. Consider truncating the data set to include only data before or after the gap, or split the data and analyze both sets separately.

For another example of using WWZ in VStar, see the following which includes the R Dor example from Foster (2010) mentioned at the start of this section.

Plug-ins

VStar’s capabilities can be extended in various ways by installing plug-ins, e.g.

- Loading observations from sources such as Kepler and ASAS.
- Filtering the loaded dataset in a custom way.
- Creating models, e.g. Loess fit.
- Performing period analysis using an algorithm other than the in-built ones.
- Transforming observations in arbitrary ways.
- Saving observations in particular formats.

See http://www.aavso.org/vstar-plugin-library for details of how to install plug-ins manually.

Alternatively, use VStar's plug-in manager, which is accessible from the Tool menu. After selecting the Plugin-Manager... menu item, the plug-in manager dialog will open:

Scrolling through the list of plug-in descriptions and selecting each one will indicate whether a plug-in can be installed or updated. If neither the Install nor the Update button is enabled, then the plug-in is up-to-date on your local machine with respect to the AAVSO plug-in archive.

A plug-in can be deleted from your system via the Delete button.

If the All? checkbox is selected, all plug-ins will be installed or deleted when the Install or Delete button is selected. The Update button is disabled when the All? checkbox is selected.
Some plug-ins require AAVSO membership status to run (e.g. APASS, BSM), but VStar will allow these to be installed, updated or deleted.

As shown in the figure above, after installing, updating, or deleting a plug-in, you will be prompted to close and restart VStar.


See the *Preferences* section for information about plug-in preferences.

Preferences

VStar allows some aspects of its functionality to be customized, for example:

- The color and size of observations in a series as they appear on a plot.
- The precision of numbers, i.e. the number of decimal places.
- The objects that appear in the Load from AAVSO International Database (AID) dialog.
- Plug-in and Locale settings.

To open the Preferences dialog, select the File → Preferences... menu item or the corresponding toolbar button.
The first tabbed pane shown above controls the color of a series observation as it appears on a plot. The series is selected from a list and the color selected. Clicking the Apply or OK buttons confirms the color change. Like all preference settings, this change persists across VStar invocations. A change can be cancelled via the Cancel button. The Set Default Colors button resets all series colors back to their “factory settings.” This is particularly important for series colors since AAVSO defines a set of standard colors for many series. This does not include synthetic series such as Filtered, Model, Residuals, Means, Excluded.

The Series Size tab controls the size of a series observation as it appears on a plot. The series is selected from a list and the size selected from another list. Clicking the Apply or OK buttons confirms the size change. The Set Default Sizes button resets all series sizes back to their “factory settings.”
On a related note, while not part of VStar's Preferences, some other aspects of a plot can be configured (for the current VStar session only) by selecting Properties… from the context menu (e.g. by right-clicking on Windows, ctrl-click on Mac OS X):
The Numeric Precision tab permits the number of decimal places to be customized for various categories of numeric values that appear as in VStar’s user interface, e.g. parameter dialog fields. The Set Default Precision Values button resets all precision values back to their “factory settings.”
The Star Groups tab permits new groups of stars to be added to the dialog that opens when File → New Star from AAVSO Database... is selected.
Suppose we want to add a new group for novae. To do so, click the Add Group button and enter the text “Novae” into the dialog, as shown.
The Preferences dialog now shows an empty **Novae** group.

The next step is to click the **Add Star** button and enter the text “V0339 Del” into the dialog, as shown.

VStar will show the busy mouse cursor as it goes away to the Variable Star Index (VSX) to ask if this object exists. If so, it will be added to the group. The Group and Stars sections of the pane
should now look like this:

![Image of VStar interface](image.png)

Click the **Apply** or **OK** button to save the change. Doing so will make the change available immediately and across VStar runs.

The **Delete Star** button deletes a star from the currently selected group.

The **Delete Group** button deletes the currently selected group.

Now suppose we want to add a new group with multiple stars all at once. To do so, click the **Add Group & Stars** button and populate the dialog that opens as shown:

![Image of new group dialog](image.png)

**See the References and Further Reading** section for details of “Southern Gems”. The **Star List** text to be entered is:

```
X Sgr, W Sgr, eta Aql, kap Pav, zet Phe, bet Dor, V Pup, alf Ori, R Dor, l Car, R Car
```

After each object has been checked (the busy mouse cursor will stop), click the **Apply** button to save the new group and its stars. Doing so will make the change available immediately and across VStar runs.
The New Star from AAVSO Database dialog will now have Novae and Southern Gems groups from which objects can be selected for loading.

The Clear button will set the groups back to “factory settings” (the Citizen Sky “10 Stars” group remains). As with all the other operations above, clicking the Apply or OK button will make the change available beyond the current run of VStar.

The Plug-in Settings preferences tab appears as follows:

and it allows:

- plug-in loading to be controlled, i.e. whether or not to load plug-ins next time VStar is started;
- all locally installed plug-ins to be deleted;
- the plug-in location URL; changing this will cause plug-ins to be loaded from a different repository, even a local directory containing a .plugins.lst file, a vstar_plugins directory and a vstar_plugin_libs directory (see Select Local Directory button);
- all observation source plugins to be shown in the File menu instead of being selectable in the file load chooser; after the checkbox state has been changed, the new setting will only take effect after VStar is restarted.

The Locale settings tab allows the user to change the locale used by VStar, e.g. for menu and dialog item names and numeric format (comma vs period to denote a decimal point). Once selected, VStar must be restarted for the change to take effect.
Log

The File menu's Log... item opens a dialog that contains all log messages for the current session.

The dialog below shows a log entry that was generated when an attempt was made to load the target “eta Far” from the AID:

The log's content can be copied to the clipboard, allowing it to be pasted into a forum message or document. The log content can also be sent via email to AAVSO. The email message is prepared for sending by the default email application if possible, as shown below:
To: vstar@aavso.org

Cc:

Bcc:

Subject: VStar Log

SEVERE: Unable to obtain information for eta Far
Scripting VStar

VStar permits some of its operations to be automated by writing a script:

- Loading observations from a file.
- Loading observations from the AAVSO International Database (AID).
- Switching between raw and phase plot mode.
- Creating a phase plot given a period and epoch.
- Saving a phase plot or light curve as a PNG image file.
- Saving a light curve to a data file.
- Performing a period search.
- Creating a model.

Currently, only the JavaScript language is supported but others may be permitted in future, such as Python or Ruby.

To run a script in VStar, select Tool → Run Script…

Doing so opens a file chooser requesting the script file to be executed.
The file chooser shows example.js being selected. Clicking the Open button will cause the script to be executed. The example script will load data for eta Aquilae in the JD range 2455821.5...2456552.5, create a phase plot, and save it as a PNG file. It will repeat this for beta Lyrae.

To try this, create a file called example.js (or whatever name you choose) with a text editor (e.g. Notepad, vi), paste in the following code, and save the file.

```javascript
root = "/Users/david/tmp/
objs = ["eta Aql", "bet Lyr"]

startJD = 2455821.5
endJD = 2456552.5
epoch = (startJD + endJD)/2

for (i=0;i<objs.length;i++) {
    // Do something with the data for each object
    // Example: phase plot
```

114
obj = objs[i]
vstar.loadFromAID(obj, startJD, endJD)

periods = vstar.dcdftPeriod("Visual", 1.0, 20.0, 0.001)

if (vstar.getError() == null) {
    vstar.phasePlot(periods[0], epoch)
    vstar.phasePlotMode()

    path = root + obj.replace(" ", ":") + "phase_plot.png"
    vstar.saveLightCurve(path, 600, 400)
}

The root path should be replaced with a path of your choosing:

    root = "/Users/david/tmp/"

This is a Mac OS X path. Under Linux, "/home/david/tmp/" would be more appropriate. For Windows, backslashes are used in paths and for use in this context, these must be “escaped” with an additional backslash, e.g. “C:\\Users\\david\\tmp\" instead of the usual “C:\Users\david\tmp\"

The script loads two objects from AID, performs a DCDFT period search with a period range of 1 to 20 days and a resolution of 0.001 days, creates a phase plot for the top-hit period (at an arbitrary epoch) and saves it to a PNG file. Once the script has completed executing, you will see a phase plot for beta Lyrae appear in VStar and the following files will be in the location corresponding to the root directory:

    bet_Lyr_phase_plot.png
    eta_Aql_phase_plot.png

Opening the second of these will reveal a phase plot for eta Aquilae, as follows:
The VStar scripting API (Application Programming Interface) should be consulted for full function details:


- [docs/vstar_docs](https://github.com/AAVSO/VStar/releases) in a release archive (https://github.com/AAVSO/VStar/releases)

The functions in the class `VStarScriptingAPI` delimited by the lines:

```java
// ** VStar scripting API methods start **
...
// ** VStar scripting API methods end **
```

constitute what is available to the script writer. The scripting API will grow in future.
## Glossary

<table>
<thead>
<tr>
<th>Term or Acronym</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td>AAVSO International Database</td>
<td>A collection of tens of millions of variable star observations spanning over a century. Maintained by the AAVSO, it is the largest digital database of variable stars in the world. See <a href="http://www.aavso.org/aavso-international-database">http://www.aavso.org/aavso-international-database</a></td>
</tr>
<tr>
<td>AAVSO Unique ID</td>
<td>A unique reference “name” for a star using the format 000-XXX-000, where the 0's are numbers (0-9) and the X’s are letters.</td>
</tr>
<tr>
<td>AIC</td>
<td>See Akaike Information Criteria.</td>
</tr>
<tr>
<td>AID</td>
<td>See AAVSO International Database.</td>
</tr>
<tr>
<td>Akaike Information Criteria</td>
<td>A measure of how well a statistical model fits a given set of data, balancing how complicated the model is. Alternate models can be compared in this way. See also BIC.</td>
</tr>
<tr>
<td>Analysis of Variance</td>
<td>A statistical test that checks whether or not variations in the data are simply noise or are statistically significant.</td>
</tr>
<tr>
<td>ANOVA</td>
<td>See Analysis of Variance.</td>
</tr>
<tr>
<td>APASS</td>
<td>The AAVSO Photometric All-Sky Survey; an ongoing project to use automated telescopes to create a photometric catalog of all stars between approximately 10th and 17th magnitude using five filters: Johnson B and V, and Sloan g’, r’, i’. See <a href="http://www.aavso.org/apass">http://www.aavso.org/apass</a></td>
</tr>
<tr>
<td>ASAS</td>
<td>All Sky Automated Survey; an ongoing project to use photometric automated telescopes to discover and observe all stars with variability (including exoplanet systems and variable stars) brighter than 14th magnitude. See <a href="http://www.astrouw.edu.pl/asas/?page=main">http://www.astrouw.edu.pl/asas/?page=main</a></td>
</tr>
<tr>
<td>AUID</td>
<td>See AAVSO Unique ID.</td>
</tr>
<tr>
<td>Band</td>
<td>A narrow region of the electromagnetic spectrum in which the magnitude is measured. A number of standard bands are frequently used, including the visual (V) band (centered on 551 Angstroms). See <a href="http://en.wikipedia.org/wiki/Photometric_system">http://en.wikipedia.org/wiki/Photometric_system</a> and <a href="http://spiff.rit.edu/classes/phys440/lectures/filters/filters.html">http://spiff.rit.edu/classes/phys440/lectures/filters/filters.html</a></td>
</tr>
<tr>
<td><strong>Bayesian Information Criteria</strong></td>
<td>Like the AIC, a statistical method for selecting which of multiple models best fits the data; it weighs the relative complexity of each model more harshly than AIC.</td>
</tr>
<tr>
<td>----------------------------------</td>
<td>-----------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td><strong>BIC</strong></td>
<td>See Bayesian Information Criteria.</td>
</tr>
<tr>
<td><strong>Binned</strong></td>
<td>Data that is grouped by a certain range of values, for example grouping variable star observations in increments of 5 Julian days. See <a href="http://pic.dhe.ibm.com/infocenter/spssstat/v20r0m0/index.jsp?topic=%2Fcom.ibm.spss.statistics.help%2Fidh_webhelp_scatter_options_palette.htm">http://pic.dhe.ibm.com/infocenter/spssstat/v20r0m0/index.jsp?topic=%2Fcom.ibm.spss.statistics.help%2Fidh_webhelp_scatter_options_palette.htm</a></td>
</tr>
<tr>
<td><strong>BSM Epoch Photometry Data</strong></td>
<td>Data from the Bright Star Monitor AAVSO database; currently there are 14 million photometric observations of approximately one million stars. See <a href="http://www.aavso.org/bright-star-monitor-epoch-photometry-database">http://www.aavso.org/bright-star-monitor-epoch-photometry-database</a></td>
</tr>
<tr>
<td><strong>Catalina Sky Survey</strong></td>
<td>An automated telescope survey of Near Earth Objects. See <a href="http://www.lpl.arizona.edu/css/">http://www.lpl.arizona.edu/css/</a> Transient phenomenon of many types (such as variable star outbursts) are also surveyed. See <a href="http://crts.caltech.edu/">http://crts.caltech.edu/</a></td>
</tr>
<tr>
<td><strong>CLEANest</strong></td>
<td>A method of refining multiple periods in variable star data simultaneously. In VStar, this can be applied to a period analysis (DCDFT) result.</td>
</tr>
<tr>
<td><strong>Comparison Star</strong></td>
<td>A star of known, constant magnitude that a nearly variable star is compared to in order to estimate the variable’s apparent brightness.</td>
</tr>
<tr>
<td><strong>Confidence Level</strong></td>
<td>The range of values for a mathematical variable for which there is high confidence (usually 95%) that the actual value lies within that range.</td>
</tr>
<tr>
<td><strong>Discrepant Data</strong></td>
<td>A data point that appears to vary significantly (well outside of normal error bars) from the mean and/or other observations taken at the same time. The AAVSO has a tool called Zapper which can be used to flag discrepant data for further investigation. See <a href="http://www.aavso.org/zapper">http://www.aavso.org/zapper</a></td>
</tr>
<tr>
<td><strong>Epoch</strong></td>
<td>In a phase plot, the initial time selected to begin the cycle (e.g. the time of the first observation or the time of minimum).</td>
</tr>
<tr>
<td><strong>Error Bar</strong></td>
<td>On a graph, lines extending above and below and/or to the</td>
</tr>
</tbody>
</table>
right and left of a data point that signify uncertainty in the measurement (usually to 95% confidence level). In VStar only error bars in magnitude are included, since uncertainty in times are not recorded in AAVSO data. Mean error bars represent the Standard Error of the Average. See also *Standard Error*.

<table>
<thead>
<tr>
<th>Term</th>
<th>Definition</th>
</tr>
</thead>
<tbody>
<tr>
<td>Fainter Than</td>
<td>A null observation of a variable star that was too faint for the instrument/observer. Since the star was not actually seen/imaged, it can only be said that at that time it was “fainter than” some limiting magnitude.</td>
</tr>
<tr>
<td>FITS</td>
<td>Flexible Image Transport System is a digital file format commonly used in astronomy and other sciences for the storage, transmission and processing of images.</td>
</tr>
<tr>
<td>Fourier Analysis</td>
<td>A power spectrum (see below) that is based on sinusoids.</td>
</tr>
<tr>
<td>Harmonics</td>
<td>The fundamental period divided by an integer (i.e. half the period, one-third the period).</td>
</tr>
<tr>
<td>Heliocentric Julian Day</td>
<td>A recalculation of the Julian date to take into account the earth’s distance from the sun; i.e. the Julian Date if the star were measured from the center of the sun. See <a href="http://www.physics.sfasu.edu/astro/javascript/hjd.html">http://www.physics.sfasu.edu/astro/javascript/hjd.html</a></td>
</tr>
<tr>
<td>HJD</td>
<td>See Heliocentric Julian Day.</td>
</tr>
<tr>
<td>JD</td>
<td>See Julian Day.</td>
</tr>
<tr>
<td>Julian Day</td>
<td>A continuous account of the days (and fractions of a day) from noon Universal Time on January 1, 4713 BCE. See <a href="https://www.aavso.org/jd-calculator">https://www.aavso.org/jd-calculator</a></td>
</tr>
<tr>
<td>Kepler</td>
<td>An exoplanet-seeking space telescope that records variations in brightness for approximately 150,000 stars in a single field of view near the Cygnus/Lyra border. In addition to discovering exoplanets (via the transit method) it also captures observations of numerous variable stars.</td>
</tr>
<tr>
<td>Light Curve</td>
<td>A plot of variations in magnitude over time.</td>
</tr>
<tr>
<td>Mean Series</td>
<td>Calculating the mean of observations for equal sized bins of Julian Dates or phase “steps” to construct a mean light curve.</td>
</tr>
<tr>
<td>Observer Code</td>
<td>A unique 3 or 4 letter code assigned to each observer by the AAVSO. Individual observations are tagged by the observer.</td>
</tr>
<tr>
<td>Term</td>
<td>Definition/Description</td>
</tr>
<tr>
<td>-------------------------------------------</td>
<td>----------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Period</td>
<td>The time between two repetitions of a cycle (often peak-to-peak).</td>
</tr>
<tr>
<td>Phase Plot</td>
<td>A plot in which the periodic data is “folded” such that, if the correct period is selected, each individual instance of the cycle aligns with the others.</td>
</tr>
<tr>
<td>Polynomial model (polynomial fit)</td>
<td>Representing data as a sum of terms of the form $\beta_i t^i$ where $i=0,1,2,...$. See Foster (2010).</td>
</tr>
<tr>
<td>Power Spectrum</td>
<td>Also known as a periodogram; A plot of frequency versus power that is used when a trial frequency is presumed in order to find periodicity in the data. Here power is a measure of the statistical significance of the fit of the trial frequency to the actual data.</td>
</tr>
<tr>
<td>Pre-whitening</td>
<td>In order to examine residuals in the data set, the strongest signal (highest peak) is removed. This permits additional periods to be searched for.</td>
</tr>
<tr>
<td>Regular Expressions</td>
<td>In computer programming a regular expression is a special text string used to describe a search pattern. See <a href="http://www.regular-expressions.info/">http://www.regular-expressions.info/</a></td>
</tr>
<tr>
<td>Residuals</td>
<td>The difference between the raw data and the model of the data. Residuals can sometimes contain valuable information, such as the existence of a second periodicity.</td>
</tr>
<tr>
<td>RMS</td>
<td>See root mean square.</td>
</tr>
<tr>
<td>Root Mean Square</td>
<td>In statistics this is the square root of the mean of a sum of a squared values (i.e. the square root of the mean of $x_1^2 + x_2^2 + x_3^2 + ... + x_n^2$).</td>
</tr>
<tr>
<td>Standard Error</td>
<td>A measure of how precise an average value of data is expected to be. In particular, for the mean series, error bars denote 95% Confidence Interval (twice Standard Error).</td>
</tr>
<tr>
<td>SuperWASP</td>
<td>A UK-based exoplanet detection consortium. See <a href="https://exoplanetarchive.ipac.caltech.edu/docs/SuperWASPMission.html">https://exoplanetarchive.ipac.caltech.edu/docs/SuperWASPMission.html</a></td>
</tr>
<tr>
<td>Variable Star Index</td>
<td>An online&quot;clearinghouse&quot; for timely information on variable stars, including suspected suspected. See <a href="http://www.aavso.org/vsx/">http://www.aavso.org/vsx/</a></td>
</tr>
<tr>
<td>VeLa</td>
<td>VStar expression Language. VeLa is a domain specific tool used for analyzing periodic data.</td>
</tr>
<tr>
<td>language created for VStar to permit numeric expressions wherever numeric constants are used (e.g. in user interface text boxes), to allow complex observation filters to be specified and to represent model equations. See <a href="https://github.com/AAVSO/VStar/wiki/VeLa">https://github.com/AAVSO/VStar/wiki/VeLa</a></td>
<td></td>
</tr>
<tr>
<td>---</td>
<td></td>
</tr>
<tr>
<td>VSX</td>
<td>See Variable Star Index.</td>
</tr>
<tr>
<td>Weighted Wavelet Z-Transform</td>
<td>An algorithm designed for analyzing variable star data, especially cases where there are period changes and/or transient phenomena (e.g. mode switching). See Foster (1996) and Templeton (2004).</td>
</tr>
<tr>
<td>WWZ</td>
<td>See Weighted Wavelet Z-Transform.</td>
</tr>
</tbody>
</table>
References and Useful Links

General Information on VStar and Variable Star Observing

**AAVSO VStar Overview and Download page:** The starting point for using VStar; includes instructions for downloading the program (including helpful hints for dealing with firewalls and other vagaries) as well as links for further instructions and tutorials. See [http://www.aavso.org/vstar-overview](http://www.aavso.org/vstar-overview)

**VStar GitHub Project page:** A source for downloading VStar for those who have difficulty downloading directly from the AAVSO website (for example, when firewalls are in use). Also, the downloadable distribution archive contains additional documents and resources that are not easy to make available via the WebStart™ download method. See [https://github.com/AAVSO/VStar](https://github.com/AAVSO/VStar)

**AAVSO Plug-in Library page:** Instructions for installing various plug-ins for VStar as well as links to those currently available. See [http://www.aavso.org/vstar-plugin-library](http://www.aavso.org/vstar-plugin-library)

**AAVSO VStar Forum:** The home page for all ongoing and past discussion of VStar, its usage, and problems users have encountered with it. See [https://www.aavso.org/forum/4997](https://www.aavso.org/forum/4997)

**AAVSO Download Format:** A detailed list and explanation of the format and terms used in AAVSO data sets. See [http://www.aavso.org/format-data-file](http://www.aavso.org/format-data-file)

**WebObs:** A portal on the AAVSO website for uploading new observations of variable stars and searching for previously uploaded observations. Note: solar observations are not included in this data set, and are found at [http://www.aavso.org/solar](http://www.aavso.org/solar). See [http://www.aavso.org/webobs](http://www.aavso.org/webobs)

**Southern Gems:** A part of the Citizen Sky Project; ten naked-eye southern hemisphere variable stars. See [http://southerngems.blogspot.com](http://southerngems.blogspot.com)
Useful Links for Period and Time Series Analysis (TS and WWZ)

**AAVSO Software Directory**: A collection of software that was developed with variable star observations and data analysis in mind. See [http://www.aavso.org/software-directory](http://www.aavso.org/software-directory)

**TS (Fortran)**: A direct link for downloading the time series statistical program. See [http://www.aavso.org/sites/default/files/software/ts.tar.gz](http://www.aavso.org/sites/default/files/software/ts.tar.gz)

**WWZ (Fortran)**: A direct link for downloading a Fortran version of WWZ. See [http://www.aavso.org/sites/default/files/software/wwz.tar.gz](http://www.aavso.org/sites/default/files/software/wwz.tar.gz)

Useful Links for Polynomial Fit


Useful Links for Regular Expressions (for Observation List Pattern Search)

*Regular Expressions*: A detailed website on the use of regular expressions in data searches, including numerous examples and tutorials. See [http://www.regular-expressions.info](http://www.regular-expressions.info)

*Regular Expressions Quick Start*: A quick tutorial on the basics of using regular expressions in data searches. See [http://www.regular-expressions.info/quickstart.html](http://www.regular-expressions.info/quickstart.html)

Further Reading


Benn, D. *VStar Blog*. A blog (with archive) category that discusses the usage of VStar as well as updates to the program.
http://dbenn.wordpress.com/category/astronomy-science/vstar

http://adsabs.harvard.edu/full/1981AJ.....86..619F

http://adsabs.harvard.edu/full/1995AJ....109.1889F

http://adsabs.harvard.edu/full/1996AJ....112.1709F


Variable Star Astronomy Chapter 12: Variable Stars and Phase Diagrams: A very basic introduction to the statistics of variable star data written for the Variable Star Astronomy (formerly Hands-on Astrophysics) curriculum.
License Information

VStar itself is licensed under the GNU Affero General Public License, the details of which can be found here: [http://www.gnu.org/licenses/agpl.html](http://www.gnu.org/licenses/agpl.html)

Like most modern software, VStar is dependent upon libraries of code written by others for some of its functionality, most notably for plotting, database access, and some statistical operations.

See [https://github.com/AAVSO/VStar/blob/master/ReadMe.md](https://github.com/AAVSO/VStar/blob/master/ReadMe.md) for the most up to date information about the libraries used by VStar.

This document is licensed under a Creative Commons Attribution (CC BY) license:

![Creative Commons Attribution License](http://creativecommons.org/licenses/by/3.0)

This license lets others distribute, remix, tweak, and build upon your work, even commercially, as long as they credit you for the original creation. This is the most accommodating of licenses offered. Recommended for maximum dissemination and use of licensed materials.

See the following links for license information:

- [http://creativecommons.org/licenses/by/3.0](http://creativecommons.org/licenses/by/3.0)
- [http://creativecommons.org/licenses/by/3.0/legalcode](http://creativecommons.org/licenses/by/3.0/legalcode)
## Revision History

<table>
<thead>
<tr>
<th>Date</th>
<th>Primary Authors</th>
<th>Comments</th>
</tr>
</thead>
<tbody>
<tr>
<td>Fri, 27 Sep 2013</td>
<td>David Benn, Kristine Larsen</td>
<td>Initial document release; for VStar 2.15.3.</td>
</tr>
<tr>
<td>Sun, 29 Sep 2013</td>
<td>David Benn</td>
<td>Resized context diagram. Added AAVSO logo to title page. Removed 2.15.3 from title page.</td>
</tr>
<tr>
<td>Sat, 15 Mar 2014</td>
<td>David Benn</td>
<td>Added note about Excel model equation format.</td>
</tr>
<tr>
<td>Fri, 9 May 2014</td>
<td>David Benn</td>
<td>Added Plugin-Manager material to Plug-ins section.</td>
</tr>
<tr>
<td>Sun, 22 Jun 2014</td>
<td>David Benn, Mike Simonsen</td>
<td>Corrections and improvements from VStar CHOICE course, May 2014 course participants (Paul York and Brad Walter). Star naming section by Mike Simonsen.</td>
</tr>
<tr>
<td>Thur, 17 Jul 2014</td>
<td>David Benn</td>
<td>Added URL request and non-AID load HJD conversion information to observation sources section. Changed Model Information dialog figures to show tabs.</td>
</tr>
<tr>
<td>Fri, 8 Aug 2014</td>
<td>David Benn</td>
<td>Additive load changes for 2.16.3.</td>
</tr>
<tr>
<td>Wed, 24 Sep 2014</td>
<td>David Benn</td>
<td>Glossary updates.</td>
</tr>
<tr>
<td>Thu, 18 Dec 2014</td>
<td>David Benn</td>
<td>Scripting section update.</td>
</tr>
<tr>
<td>Fri, 3 Jul 2015</td>
<td>David Benn</td>
<td>Updates for 2.16.8.</td>
</tr>
<tr>
<td>Tue, 11 Aug 2015</td>
<td>David Benn</td>
<td>Added information about use of commas to observation source section.</td>
</tr>
<tr>
<td>Sun, 6 Dec 2015</td>
<td>David Benn</td>
<td>Updated plug-in manager text and plug-in preferences section.</td>
</tr>
<tr>
<td>Wed, 6 Jan 2016</td>
<td>David Benn</td>
<td>Updated scripting section.</td>
</tr>
<tr>
<td>Sat, 30 Apr 2016</td>
<td>David Benn</td>
<td>Updated observation source section for 2.17.0.</td>
</tr>
<tr>
<td>Sat, 6 May 2017</td>
<td>David Benn</td>
<td>Updated plot control dialog, filters, and preferences sections.</td>
</tr>
<tr>
<td>Date</td>
<td>Primary Authors</td>
<td>Comments</td>
</tr>
<tr>
<td>------------------</td>
<td>-----------------</td>
<td>------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Wed, 24 May 2018</td>
<td>David Benn</td>
<td>Updated observation source, observation detail dialog, filters, and preferences sections, added log section for 2.20.0.</td>
</tr>
<tr>
<td>Sun, 3 May 2020</td>
<td>David Benn</td>
<td>Updated sections: observation source, observation list search, information dialog, phase plot, period analysis, information dialog, plug-in preferences, time-frequency analysis, filtering observations, plot control, polynomial fit, references, glossary, and improved equation rendering for 2.21.0. Removed star naming section since AAVSO web resources available for this.</td>
</tr>
<tr>
<td>Sun, 9 May 2020</td>
<td>David Benn</td>
<td>Updated revision number for 2.21.1 release.</td>
</tr>
<tr>
<td>Wed, 12 Aug 2020</td>
<td>David Benn</td>
<td>Updated revision number for 2.21.2 release.</td>
</tr>
<tr>
<td>Mon, 17 May 2020</td>
<td>David Benn</td>
<td>Updated revision number for 2.21.3 release. Updated Plug-in Manager section. Changed URLs to refer to GitHub instead of SourceForge.</td>
</tr>
</tbody>
</table>