Skip to main content

astrometry.net availabillity

13 posts / 0 new
Last post
David Benn
David Benn's picture
astrometry.net availabillity

For the past 2 or 3 days I've been trying to plate solve with AstroImageJ which uses astrometry.net 

http://nova.astrometry.net appears to be unavailable. Just me or have others seen this too?

David 

clkotnik
clkotnik's picture
Plate Solve Problems

I just tried a plate solve via astronmetry.net via AIJ and MaximDL.  Both failed.

 

Cliff

pablotwa
pablotwa's picture
Thank you!, THANK YOU!

I thought I was going crazy, plate solving failed twice while using sequence generator plus and I finally realized it was them, thank you for corroborating. 

Pablo

David Benn
David Benn's picture
Outage

No worries Pablo and thanks Cliff.

I should've noticed ths before:

  https://groups.google.com/forum/#!topic/astrometry/Rz11VZ9xldE

Looks like there's an outage and an alternative URL has to be used at the moment:

  http://nova2.astrometry.net

I'll try this in AIJ and see how it goes.

David

pablotwa
pablotwa's picture
Thank you.

Thanks David, that link works.

Pablo

David Benn
David Benn's picture
Changing AIJ astrometry URL?

Hmm. Now that we have a new (temporary I guess) URL, how to change it in AIJ? Have you guys found a way to do this? I don't see anything in options/prefs and haven't found anything on the web yet.

Just visited http://nova.astrometry.net again and it looks like they're doing a rebuild since the default Apache Ubuntu page is there.

David

clkotnik
clkotnik's picture
Change Astrometry URL

David,

With an image open, click the tool icon for astrometry (red cross over blue cirlce).  You will get the dialog in the attached image.  It looks like you just enable the custom server and put in the URL.  I've not tried this, so let me know how it goes.

Cliff

File upload: 
David Benn
David Benn's picture
AIJ 3.1.0

Thanks Cliff. My version of AIJ is 3.1.0 and that dialog doesn't allow a custom URL, so I need to update. Getting 3.2.0 now.

What version do you have?

David

David Benn
David Benn's picture
Account and API key change

So it looks like there's been an account and API key change as well. My current key (via web login) is different from the one I had been successfully using.

Now with the changed URL and key, the WCS process starts but then each submission fails. Note that this is different from the login error I was previously seeing.

David

clkotnik
clkotnik's picture
Success, but don't understand

Don't you hate it when something works, but you don't understand why?

I'm using AIJ ver 3.2.1.  I opened an image and tried a plate solve without having changed to nova2.astrometry.net.  It failed as expected.  I then opened the astrometry settings dialog, enabled the custom server and entered the nova2 URL.  I did not change my key which is a year or so old.  I also enabled the log.  This failed, indicating a login error.  I disabled the custom server and, for the heck of it, tried the plate solve again.  It failed once with a timeout (no surprise), but AIJ tried it again and it succeeded.  I did verify that the coordinates were correct on this image that I had not plate solved previously.  Here is my log:

[2017-06-18T08:45:46.185]      Astrometry.net login error, exiting.
*****PLATE SOLVE FAILED*****
[2017-06-18T08:47:58.135]      Astrometry submission ID 1615275 timed out for SA32B-C14-20170615@033223-070S-B1-W-R.fts. Resubmitting.
[2017-06-18T08:48:29.609]      Astrometry job 2108820 for SA32B-C14-20170615@033223-070S-B1-W-R.fts: SOLVED
*****PLATE SOLVE FINISHED*****

Now, if I reenable the custom server I can see that the nova2 URL has been cached.  Perhaps after you enter the custom server URL, AIJ tries it if the primary URL fails even with the custom server disabled?

Now this will certainly slow things down, but perhaps this same trick will work for you.

Good luck,

Cliff
 

David Benn
David Benn's picture
Still failing

Thanks Cliff.

I tried your enable-disable-enable suggestion. It submits but quickly gives a series of errors like this:

[2017-06-19T08:02:13.206]      Astrometry submission 527 doesn't exist yet for slice 1 : Read timed out
[2017-06-19T08:02:15.688]      Astrometry job 530 for slice 1: failure. Resubmitting.
[2017-06-19T08:02:26.316]      Astrometry job 531 for slice 1: failure. Resubmitting.
[2017-06-19T08:02:26.317]      Astrometry job 531 for slice 1 was unsuccessful after 2 tries. Skipping Image.
[2017-06-19T08:02:35.226]      Astrometry job 532 for slice 2: failure. Resubmitting.

Now trying to go back to nova.astrometry.net which seems to be up again... OAuth login is failing there now. Try again later. Need to get my old key back or create a new one (which I carelessly failed to record when switching URLs).

If all else fails I'll try to run it locally.

David

David Benn
David Benn's picture
Okay, so this astrometry.net

Okay, so this astrometry.net forum thread is active (as in today):

  https://groups.google.com/forum/#!topic/astrometry/A30cCLu0gN4

Definitely people seeing similar issues.

David

David Benn
David Benn's picture
There was indeed a problem

There was indeed a problem which now appears to be fixed. See https://groups.google.com/forum/#!topic/astrometry/A30cCLu0gN4

David

Log in to post comments
AAVSO 49 Bay State Rd. Cambridge, MA 02138 aavso@aavso.org 617-354-0484